当前位置:首页 > 问答

瀑布线改进通达信

我来帮TA回答

求高手老师编一个通达信瀑布线选股公式

请提供你认为的瀑布线指标原码
我可以帮你改写,联系我

能帮我做一个通达信瀑布线的选股公式吗?

PBX1:=(EMA(CLOSE,4)+MA(CLOSE,4*2)+MA(CLOSE,4*4))/3;
PBX2:=(EMA(CLOSE,6)+MA(CLOSE,6*2)+MA(CLOSE,6*4))/3;
PBX3:=(EMA(CLOSE,9)+MA(CLOSE,9*2)+MA(CLOSE,9*4))/3;
PBX4:=(EMA(CLOSE,13)+MA(CLOSE,13*2)+MA(CLOSE,13*4))/3;
PBX5:=(EMA(CLOSE,18)+MA(CLOSE,18*2)+MA(CLOSE,18*4))/3;
PBX6:=(EMA(CLOSE,24)+MA(CLOSE,24*2)+MA(CLOSE,24*4))/3;
{第一次出现符合}
YT:=PBX1>=PBX2 AND PBX2>=PBX3 AND PBX3>=PBX4 AND PBX4>=PBX5 AND PBX5>=PBX6;
选股:CROSS(PBX5,PBX6)AND YT;

求高手帮我写个瀑布线(PBX)粘合选股公式

M1:=4;M2:=6;M3:=9;M4:=13;M5:=18;M6:=24;
PBX1:=(EXPMA(CLOSE,M1)+MA(CLOSE,M1*2)+MA(CLOSE,M1*4))/3;
PBX2:=(EXPMA(CLOSE,M2)+MA(CLOSE,M2*2)+MA(CLOSE,M2*4))/3;
PBX3:=(EXPMA(CLOSE,M3)+MA(CLOSE,M3*2)+MA(CLOSE,M3*4))/3;
PBX4:=(EXPMA(CLOSE,M4)+MA(CLOSE,M4*2)+MA(CLOSE,M4*4))/3;
PBX5:=(EXPMA(CLOSE,M5)+MA(CLOSE,M5*2)+MA(CLOSE,M5*4))/3;
PBX6:=(EXPMA(CLOSE,M6)+MA(CLOSE,M6*2)+MA(CLOSE,M6*4))/3;
ABS(PBX1-PBX2)/PBX2<0.003 AND ABS(PBX2-PBX3)/PBX3<0.003 AND ABS(PBX3-PBX4)/PBX4<0.003 AND PBX1>REF(PBX1,1) AND PBX2>REF(PBX2,1);

如何修改通达信瀑布线颜色

PBX1:(EXPMA(CLOSE,M1)+MA(CLOSE,M1*2)+MA(CLOSE,M1*4))/3,COLORGREEN;
PBX2:(EXPMA(CLOSE,M2)+MA(CLOSE,M2*2)+MA(CLOSE,M2*4))/3,COLORGREEN;
PBX3:(EXPMA(CLOSE,M3)+MA(CLOSE,M3*2)+MA(CLOSE,M3*4))/3,COLORGREEN;
PBX4:(EXPMA(CLOSE,M4)+MA(CLOSE,M4*2)+MA(CLOSE,M4*4))/3,COLORGREEN;
PBX5:(EXPMA(CLOSE,M5)+MA(CLOSE,M5*2)+MA(CLOSE,M5*4))/3,COLOR0099FF;
PBX6:(EXPMA(CLOSE,M6)+MA(CLOSE,M6*2)+MA(CLOSE,M6*4))/3,COLORYELLOW;

顾比均线的通达信源码

E3:EMA(C,3),COLOR61DC16;
E5:EMA(C,5),COLOR61DC16;
E8:EMA(C,8),COLOR61DC16;
E10:EMA(C,10),COLOR61DC16;
E12:EMA(C,12),COLOR61DC16;
E15:EMA(C,15),COLOR61DC16;
E30:EMA(C,30),COLORD1875A;
E35:EMA(C,35),COLORD1875A;
E40:EMA(C,40),COLORD1875A;
E45:EMA(C,45),COLORD1875A;
E50:EMA(C,50),COLORD1875A;
E60:EMA(C,60),COLORD1875A;
IF(E3>REF(E3,1),E3,DRAWNULL),COLORYELLOW;
IF(E5>REF(E5,1),E5,DRAWNULL),COLORYELLOW;
IF(E8>REF(E8,1),E8,DRAWNULL),COLORYELLOW;
IF(E10>REF(E10,1),E10,DRAWNULL),COLORYELLOW;
IF(E12>REF(E12,1),E12,DRAWNULL),COLORYELLOW;
IF(E15>REF(E15,1),E15,DRAWNULL),COLORYELLOW;
IF(E30>REF(E30,1),E30,DRAWNULL),COLORFF00FF;
IF(E35>REF(E35,1),E35,DRAWNULL),COLORFF00FF;
IF(E40>REF(E40,1),E40,DRAWNULL),COLORFF00FF;
IF(E45>REF(E45,1),E45,DRAWNULL),COLORFF00FF;
IF(E50>REF(E50,1),E50,DRAWNULL),COLORFF00FF;
IF(E60>REF(E60,1),E60,DRAWNULL),COLORFF00FF;
STICKLINE(C>O,C,O,1,0),COLORRED;
STICKLINE(C>O,H,L,0,0),COLORRED;
STICKLINE(C<=O,C,O,1,0),COLORFFFF52;
STICKLINE(C<=O,H,L,0,0),COLORFFFF52;
DRAWICON(EMA(C,8)>EMA(C,15) AND EMA(C,40)>REF(EMA(C,40),1) AND CROSS(EMA(C,3),EMA(C,35)),L-0.20,24);
DRAWICON(EMA(C,15)>EMA(C,40) AND EMA(C,35)>REF(EMA(C,35),1) AND CROSS(EMA(C,3),EMA(C,5)),L-0.20,25);
DRAWICON(ABS(EMA(C,15)-EMA(C,60))/C<0.01 AND EMA(C,15)>EMA(C,30) AND O<EMA(C,3) AND C>EMA(C,3) AND O<EMA(C,15) AND C>EMA(C,15) AND O<EMA(C,30) AND C>EMA(C,30) AND O<EMA(C,60) AND C>EMA(C,60),L-0.20,27);
DRAWICON(ABS(EMA(C,45)-EMA(C,30))/C<0.011 AND EMA(C,3)>EMA(C,15) AND EMA(C,15)>EMA(C,40) AND CROSS(EMA(C,5),EMA(C,60)),L-0.20,13);
A1:=OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60);
A2:=C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60)));
A3:=V/MA(V,10)>1.2;
A4:=C/REF(C,1)>1.049;
出水芙蓉:=A1 AND A2 AND A3 AND A4 AND O<EMA(C,60) AND C>EMA(C,60);
DRAWICON(出水芙蓉,L-0.20,9);

如何写一个 通达信MA移动平均价公式

均价:=(HIGH+OPEN+LOW+CLOSE)/4;
VMA1:MA(均价,5);
VMA2:MA(均价,10);
VMA3:MA(均价,20);
VMA4:MA(均价,30);
VMA5:MA(均价,60);
  • 财惠网
  • 炒股配资网
  • 巨财网
  • 黄金喊单
  • 原油直播室
  • 原油期货网
  • 原油期货
  • 期货直播间
  • 黄金喊单
  • 外盘期货喊单
  • 期货直播室
  • 恒指喊单直播室
  • 期货直播室
  • 薛城财经
  • 国际期货喊单
  • 助腾财经
  • 黄金喊单
  • 中银网
  • 恒指期货直播
  • 美原油直播室
  • 黄金喊单
  • 金融知识科普网
  • 亿森财经
  • >凯贝股票网
  • 财姐网
  • >东台网
  • 广东炒股网